1. #1
    Avatar von Monzetsu1470 Junior Mitglied
    Registriert seit
    Jan 2014
    Beiträge
    66

    BUG: KI-Schiff ist stundenlang inaktiv und blockiert meinen Hafen

    Obwohl es so heiß zocke ich doch gerade intensiv Anno 1800:

    Da bin auf folgendes Problem gestoßen: Und zwar ist ein seit Stunden ein KI-Schiff inaktiv und blockiert meinen Hafen.

    Was ich bereits versucht habe und nichts bewirkt hat.

    1. Hafen umgebaut um Freifläche zu schaffen -> kein Erfolg
    2. KI-Schiff mit meinen Schiffen weggeschubst um Weiterfahrt zu triggern -> kein Erfolg
    3. Spiel gespeichert, Spiel beendet, Uplay beendet, Uplay gestartet, Spiel gestartet, akt. Spielstand fortgesetzt -> kein Erfolg.
    4. Das ein KI-Schiff im meinem Ingame-Hafen so lange inaktiv liegt, deutet ja meistens daraufhin, dass eine Quest getriggert werden soll. Also habe ich alle Häfen dieser KI gründlich abgesucht. Kein Quest-Sternchen war zu sehen. (sowohl in der alten als auch in der Welt)
    5. Zellenwechsel in die neue Welt und zurück in die Alte -> Weiterfahrt wird nicht getriggert.

    Da ich mir auch ziemlich sicher bin, dass dieser Bug bekannt ist. Hat jemand irgendwie bereits eine provisorische Lösung dafür gefunden, außer derjenigen: Krieg zu führen, dass kommt momentan für mich nicht in Frage?



    PS Bild ist nach 1. und 2. entstanden.
    Share this post

  2. #2
    Avatar von Lemminck Forum Veteran
    Registriert seit
    Feb 2014
    Beiträge
    1.513
    In der Größenordnung nicht, aber auch bei mir hängt sein Stunden 1 Schiff von genau diesem Herrn Malching in meinem Hafen rum, zum Glück stört es meine Schiffe nicht, da es "passend" liegt. Ein Screenie kommt ggf später,( kann mir auf der Arbeit ja schlecht Anno installieren, sogern ich auch würde). Hatte auch mal kurz nen paar Gebäude verschoben, das hat nur dazu geführt, das Malchings Schiff dann mal kurz unter der extra über dem Schiff platzierten Werft kurz zur Seite gefahren ist usw. Weggefahren ist es dadurch auch nicht.

    Bei mir wie gesagt nicht weiter störend, daher mir auch halbwegs egal, solange es nicht mehr- oder meine Schiffe dadurch gestört werden. Was bei dir ggf. helfen könnte ist eine Piratenflagge, dann kannst du das Schiff zerschießen ohne gleich Krieg mit van Malching zu haben.

    Aber schon auffällig, dass es bei uns beiden von Herrn Malching ist.
    Share this post

  3. #3
    Avatar von Monzetsu1470 Junior Mitglied
    Registriert seit
    Jan 2014
    Beiträge
    66
    Erst einmal vielen Dank für Deinen Kommentar. Jetzt wird es aber noch verrückter. Denn ich hatte noch eine Piratenflagge in meinem Inventar. Habe die in einer Fregatte aktiviert. Es steht da geschrieben, Schiff befindet sich im Piratenmodus. Aber ich kann das KI-Schiff trotzdem ncht angreifen. Es erscheint kein roter Kreis. Nur der grüne bleibt.
    Share this post

  4. #4
    Avatar von Lemminck Forum Veteran
    Registriert seit
    Feb 2014
    Beiträge
    1.513
    Zitat von Monzetsu1470 Go to original post
    Erst einmal vielen Dank für Deinen Kommentar. Jetzt wird es aber noch verrückter. Denn ich hatte noch eine Piratenflagge in meinem Inventar. Habe die in einer Fregatte aktiviert. Es steht da geschrieben, Schiff befindet sich im Piratenmodus. Aber ich kann das KI-Schiff trotzdem ncht angreifen. Es erscheint kein roter Kreis. Nur der grüne bleibt.
    Das ist allerdings höchstinteressant, ich gucke heute abend/nacht(Feierabend um 22, dann nach Haus KALT!!! Duschen etc also erwarte vor Mitternacht nicht allzuviel) mal sehen, ob ich so eine Flagge auftreiben kann und das auch bei mir so ist. Sehr suspekt das ganze jedenfalls.
    Share this post

  5. #5
    Avatar von Monzetsu1470 Junior Mitglied
    Registriert seit
    Jan 2014
    Beiträge
    66
    Jetzt ist mir doch evlt. die Ursache eingefallen, allerdings nicht die Lösung. Ich habe von dem guten Herrn diese Bug-Quest (grauer Kasten, konnte die nicht machen).

    https://forums-de.ubi.com/showthread...rauch+aufgehen

    Habe dann mit x beendet. Evtl. ist das Schiff davon übrig geblieben. Aber nujr eine Vermutung.
    Share this post

  6. #6
    Avatar von Lemminck Forum Veteran
    Registriert seit
    Feb 2014
    Beiträge
    1.513
    So, Feierabend

    Die ersten beiden Fotos sind aus etwas älteren Saves, aber gleicher Spielstand wie das dritte, was topaktuell ist, interessanterweise ist dort das Schiff von Malching nicht mehr zu sehen, ich hatte aber auch ewig nicht mehr danach geschaut, wozu auch^^

    1 Hier Malchings Schiff in meinem Hafenbereich

    2 Hier habe ich für den zweiten Screen mal kurz die Werft versetzt, wie unglaublich weit Malchings Schiff sich dadurch bewegt hat sieht man ja

    3 Hier ist es tatsächlich weg, und nein es befindet sich nicht unter den Öldepots Habe die zum Testen tatsächlich kurz abgerissen, in der Tat nur H²O zu sehen danach, soll ja auch so sein.


    Das mit der Quest könnte! in der Tat eine Ursache sein, alles mit grauem Kästchen wird eh weggeklickt und da ich kaum Kriegsschiffe baue werden auch nahezu sämtliche Geleitschutz oder Zerstörungsaufgaben geskippt. Leider kann ich das mit der Piratenflagge allerdings nun doch nicht mehr testen, da es wie gesagt ja mittlerweile dann doch weg ist, Fragen über Fragen
    Share this post

  7. #7
    Avatar von MusicMixer99 Neuzugang
    Registriert seit
    May 2019
    Beiträge
    18
    Also ich kann euch mitteilen, dass sich das Problem nicht nur auf den Malching beschränkt... Bei mir steckt nämlich Madame Kahinas Klipper seit mehreren Stunden "fest"
    Hatte diesbezüglich auch schonmal einen Beitrag aufgemacht, kam nix hilfreiches zurück...
    https://forums-de.ubi.com/showthread...85#post2627885
    Share this post

  8. #8
    Avatar von LadyHahaa Moderator
    Registriert seit
    Jul 2007
    Ort
    Offenbach
    Beiträge
    8.047
    Kleiner Tipp als Workaround
    durch geschicktes Manövrieren mit dem eigenen Schiff, kann man diese fremden Schiffe einfach dort weg schubsen.
    Share this post