PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : (Siedler IV) Siedler 4 FAQ, Netzwerk, Fehler, Bugs



Kristalikadi
15-11-18, 23:38
FAQ - Hier findet ihr sämtliche Bugs die wir bereits gefunden haben und auch Lösungen.

EDIT: Da die fragen immer wieder kommen. Die meisten Bugs sind bekannt. Es werden in diesem Post nicht alle Bugs behandelt, lediglich Gamebreaking Bugs und Infos für den Multiplayer.
----------------------------------------------------------------------
Hallo zusammen, da immer wieder die gleichen Probleme auftreten für das spielen im Mehrspieler hier eine Liste mit den Wichtigsten und nützlichsten Informationen.

Von Spielern für Spieler ;)

Folgende Themen werden behandelt.

1. - Ports - Router Freigaben - Spiel beitreten
1.1 -Mehrspieler Infos - Fragen
2. - Bekannte Bugs und Lösungen
2.1 - Alte Steuerung/Klassische Steuerung


1. Ports - Router Freigaben - Spiel beitreten

Edit: Eine genauere Hilfe wie man das mit den gängigen Routern macht wird von mir bei Zeiten nachgeliefert.

Für alle die jetzt noch Probleme mit dem Joinen/Hosten haben. "Fehler beim Verbindungsaufbau", folgende Ports müssen im Router als UDP eingetragen werden.
3074
3105
1005
1100
6200
6300

ACHTUNG: Die Freigabe funktioniert auf jedem Router anders! Bitte lest euch die Beschreibung eures Routers durch oder fragt freunde die sich damit auskennen falls Ihr es nicht selbst hin bekommt. Ältere Speedport Router sind bekannt dafür Probleme bei der Portfreigabe zu haben!

https://i.imgur.com/AUZfpYD.png

WICHTIG sucht nach der Funktion "Selbstständige Port Freigaben für dieses Gerät erlauben." oder UPnP-Standard (Universal Plug and Play).

Edit: Bei mir funktioniert es nur damit da der Port 3074 als UDP erst dann freigegeben wird. Einen genauen Grund hierfür habe ich noch nicht finden können.
----------------------------------------------------------------------------------------------------------------------------------------------------
1.1 Mehrspieler Infos

Kann man über Lan spielen?
Ja das funktioniert aber, nur wenn beide Spieler das Spiel über Uplay gekauft haben und sich in einem Netzwerk befinden.

Sollten zwei Spieler im selben Haus (gleiche Netzwerkverbindung) online spielen wollen muss derjenige der die Ports freigegeben hat das Spiel hosten und der zweite über Lan joinen. Erst dann können weitere Onlinespieler eingeladen werden.


Wie trete ich einem Spiel bei?

Bevor Ihr in ein Spiel Joinen könnt MÜSST Ihr das Spiel gestartet haben und im Hauptmenü sein.
Erst dann kann man über Shift+F2 (Umschalt+F2) --> Freunde --> Freund anklicken und Joinen.
Alternativ kann die Person auch Invited werden ABER nur wenn man bereits im Hauptmenü ist.


Schnelles Spiel geht das?

Die Schnelle Spiel Suche funktioniert! Aber nicht wie man sich das vorstellt.
Wenn man auf schnelles Spiel klickt wählt man eine Map aus die man mit anderen Spielen möchte und drückt auf weiter.
Sobald ein zweiter Spieler über schnelles Spiel in der Mehrspieler Lobby die gleiche Map angeklickt hat (Ohne Einstellungen zu verändern) Joint dieser in die Lobby des ersten Spielers.

Das ganze funktioniert nach unseren Tests nicht mit Random Karten sondern nur mit den vorhandenen Multiplayer Karten und den Custom Maps.


2. Bekannte Bugs und Lösungen

Crash nach Spielbeginn (Nur Multiplayer)

Bisher sind folgende Probleme bekannt.
Direkt nach dem Start crasht das Spiel bei einer oder mehreren Personen sobald das erste Gebäude gebaut wurde.


2.1 - Alte Steuerung/Klassische Steuerung

In Siedler 4 History Edition gibt es eine neue Steuerung welche aber derzeit noch Fehler enthält.
Die Klassische Steuerung erhält man indem man im Uplay Launcher Siedler 4 startet und die Konfiguration startet. Dort kann man auch den Haken für die Klassische Steuerung setzen.

Vorspulen (F12 ist jetzt auf F9)

https://i.imgur.com/Nmupucu.png

Dieser Beitrag wird aktualisiert sobald weitere Informationen vorliegen. Mit diesen Tipps solltet Ihr das Spiel zu 99% im Mehrspieler lauffähig bekommen.

Bei Fragen oder Problemen bitte die bisher vorhanden Beiträge überprüfen.

Offizielles Ubisoft FAQ

https://support.ubi.com/de-DE/faqs/000039550/Verbindungsschwierigkeiten-in-The-Settlers-History-Collection-TSHC/

Edit: Danke an die Mods :)

Viel Spaß
Kristalikadi

ThoNic232352355
16-11-18, 01:57
Hallo zusammen,

Sehr gute Beitrag Kadi, der sollte angepinnt werden, das betrifft in erster Linie das Verbindungsproblem und die dazugehörige Fehlermeldung.

Bei mir lief das Spiel zunächst nicht, obwohl ich alle Ports freigeschalten habe. Bei mir lag das Problem bei der UPnP Freigabe für Netzwerkverbindungen, da fehlte ein Häckchen.
Für weitere Fragen hilft euch hier das Forum oder auch die aktiven User z.B. im Teamspeak (englisch und deutsch).
TS-Servername: e91.myds.me
PW: TerraNova

Desweiteren haben wir aktiven Spieler eine Siedler 4 Gruppe erstellt, hierzu werde ich noch einen separaten Beitrag öffnen.
Dieser ist wichtig, damit ihr Mitspieler findet und die Community über diese Gruppe wächst und man sich zum Spiel absprechen kann.

MfG & Viel Spaß


ThoNic

haep
16-11-18, 02:04
Danke für den Beitrag Kristalikadi, ist angepinnt!

Hier auch nochmal dier Starter Guide für alle Spiele der HC:
https://forums-de.ubi.com/showthread.php/199452-History-Collection-Starter-Guide-SPRACHE-SAVEGAMES-etc

Ramstein2005
16-11-18, 03:52
hm und was machen die mit IPv6 ?
Mir wäre neu das ma da Ports freigeben kann, geschweige denn NAT

Kristalikadi
16-11-18, 08:01
hm und was machen die mit IPv6 ?
Mir wäre neu das ma da Ports freigeben kann, geschweige denn NAT
Also ich weiß ja nicht was du für einen Router hast aber mit meiner Fritzbox kann ich IPv6 sogar gleichzeitig mit IPv4 anlegen lassen. Oder halt separat. Auch die UPnP funktion. ;)

Edit: Die Frage ist eher ob Siedler 4 IPv6 unterstützt.

Edit2: Ich muss mich ein wenig korrigieren. Es scheint über IPv6 zumindest nicht auf die übliche Art möglich zu sein. Bitte mal im Router die Möglichkeit nach PortMapping absuchen und sich darüber Informieren.

Ubi-Thorlof
16-11-18, 11:58
Unsere Kollegen vom Support haben zusätzlich ein FAQ zu Verbindungsschwierigkeiten erstellt:
https://support.ubi.com/de-DE/faqs/000039550/Verbindungsschwierigkeiten-in-The-Settlers-History-Collection-TSHC/

haep
16-11-18, 17:17
Habe die Ports in der FAQ kurz aktualisiert, wir haben inzwischen die Info, dass es sich um UDP Ports handelt.
@Kristalikadi: Wenn du magst könntest du den Screenshot dazu auch noch aktualisieren. :)

Lukadora95
16-11-18, 23:02
Bei mir lässt sich in der Konfiguration die klassische Steuerung nicht aktivieren, sie ist zwar angekreuzt aber es wird nicht im Spiel übernommen.

Vielleicht ist es nur bei funktionierender Klassischen Steuerung, aber weiss jemand ob es die Spielgeschwindigkeit noch gibt? Im Singleplayer konnte ich immer zwischen verschiedenen Geschwindigkeiten wechseln über den Num Block, das würd ich gern auch hier tun.

Lukadora95
16-11-18, 23:04
doppelpost
(Sry, Forum gab nen Captcha-Fehler aus, hat aber trotzdem gepostet offenbar)

mika_465
16-11-18, 23:31
Hallo miteinander!
Ich hoffe mal, dass ich hier an der richtigen Stelle im Forum bin.

Ich habe noch immer das Problem, dass bei Multiplayer-Spielen mit anderen Spielern und KI's das Spiel nach einer Zeit einen DESYNC-Fehler anzeigt. Das heißt dann, dass das Spiel dann beim Mitspieler komplett anders ist als bei mir, als würden wir gar nicht mehr zusammenspielen.
Ich hatte gehofft das das Problem mit der History-Edition behoben wurde, das war eigentlich der Hauptgrund für meinen Kauf, da der LAN Multiplayer mit der alten Version immer gut funktioniert hatte (außer eben diesem DESYNC bug).
Das automatische Speichern ist bei mir auf 15 Minuten gestellt.

Viele Grüße,

Mika

Kristalikadi
16-11-18, 23:34
Bei mir lässt sich in der Konfiguration die klassische Steuerung nicht aktivieren, sie ist zwar angekreuzt aber es wird nicht im Spiel übernommen.

Vielleicht ist es nur bei funktionierender Klassischen Steuerung, aber weiss jemand ob es die Spielgeschwindigkeit noch gibt? Im Singleplayer konnte ich immer zwischen verschiedenen Geschwindigkeiten wechseln über den Num Block, das würd ich gern auch hier tun.

Die Klassische Steuerung bedeutet hauptsächlich das die Mausbewegung für das bewegen auf der Map invertiert wird.
https://forums-de.ubi.com/showthread.php/199541-Siedler-IV-History-Edition-Geschwindigkeits%E4nderung-%FCber-1-2-3-geht-nicht?p=2570012

@mika_465 Der Dsync Bug ist bekannt. Wird noch untersucht, ob eine Lösung machbar ist wird sich zeigen. Nächste Woche gibts mehr Infos denke ich.

Lukadora95
17-11-18, 02:17
Wie steht es um klassische LAN Multiplayer?

Kristalikadi
17-11-18, 10:04
Wie steht es um klassische LAN Multiplayer?
Funktioniert aber, nur wenn beide Spieler das Spiel über Uplay gekauft haben und sich in einem Netzwerk befinden.

Sollten zwei Spieler im selben Haus (gleiche Netzwerkverbindung) online spielen wollen muss der jenige der die Ports freigegeben hat das Spiel hosten und der zweite über Lan joinen. Erst dann können weitere Onlinespieler eingeladen werden.

Lukadora95
17-11-18, 14:24
Wir finden uns gegenseitig im selben Netzwerk (auch beide uPlay Fassung), jedoch tritt immer "Fehler beim Verbindungsaufbau" auf sobald man versucht zu joinen.

muf
17-11-18, 16:14
Wir finden uns gegenseitig im selben Netzwerk (auch beide uPlay Fassung), jedoch tritt immer "Fehler beim Verbindungsaufbau" auf sobald man versucht zu joinen.


Wie genau versucht Ihr das Spiel zu starten? Normal müsste es reichen wenn einer ein Spiel aufmacht und der andere müsste es dann als auswahlbar sehen und joinen können. Die Invite Funktion wird hingegen immer über uplay gehen.

Lukadora95
17-11-18, 16:22
genau, das Spiel wird angezeigt in der Liste. Es erscheint jedoch "Fehler beim Aufbau der Verbindung".
Sowohl mit Invite, Beitreten oder einfachem Auswählen aus der Liste. Dürfen wir ggf. gar nicht befreundet sein?

kdsystem1337
17-11-18, 16:59
Dieses Problem hat bei uns einer der beiden lokalen Clients auch, den Host schon einmal gewechselt?

Lukadora95
17-11-18, 17:29
Jop, Host haben wir auch schon gewechselt, funktioniert beidseitig nicht. Firewalls etc. komplett deaktiviert.

kdsystem1337
17-11-18, 18:35
Habt ihr beide die Ports im Router aktiviert?
Bei mir haben beide automatisch einen UDP Port bekommen. (64170,3074)

Lukadora95
17-11-18, 19:05
Naja das geht ja sc

Lukadora95
17-11-18, 19:06
Naja das geht ja schlecht im selben Netzwerk. Aber ich hab sie noch auf mich freigegeben.

kdsystem1337
17-11-18, 19:08
Also ich meinte eigentlich:

Die automatische Protfreigabe erzeugt für beide jeweils EINEN port, das Funktioniert dann bei mir (fritz.box).

Lukadora95
17-11-18, 23:43
Das hat perfekt funktioniert bei uns, wusst ich nicht. Vielen Dank dafür :)

Leider kann ich den Bug eines Kollegen hier nur bestätigen. Das Spielen mit KI führt weiterhin zum DESYNC Error. Bei uns kam er nach einer Stunde.

Kristalikadi
18-11-18, 01:27
Das hat perfekt funktioniert bei uns, wusst ich nicht. Vielen Dank dafür :)

Leider kann ich den Bug eines Kollegen hier nur bestätigen. Das Spielen mit KI führt weiterhin zum DESYNC Error. Bei uns kam er nach einer Stunde.

Das mit der "automatischen Portfreigabe" hab ich eh im ersten Post beschrieben. Wer lesen kann "hust hust" :p ;)

Lukadora95
18-11-18, 02:17
Ich habe die Macht des UPnP unterschätzt :D Sorry :o

Mir war nicht klar das intern die gleichen Ports untereinander so freigegeben werden können. Man lernt nie aus haha.
Haben grad unsere 1vs1 Partie abgeschlossen, es läuft einfach genial flüssig und störfrei wenn man sich an alle Tipps hält, wobei die Autospeicher-Funktion die hier im Thread beschriebenen Abstürze nicht hervorgerufen hat. Jetzt muss nur noch das Spielen mit KI funktionieren und mein gefühlt innerster Traum geht in Erfüllung. Eine gemeinsame Schlacht :p:D:D

Kristalikadi
18-11-18, 12:05
Es sind nicht die Autosaves die zu einem garantierten Absturz führen. Sondern wenn du Manuell speicherst und NUR wenn du eine Random generierte Map nutzt. Hab ich aber auch im ersten Thread erklärt. Bitte aufmerksam lesen. Von automatischen speichern habe ich nichts geschrieben. :confused: ;)

Lord_Nugget
18-11-18, 15:39
In meiner Freundesliste auf U play hat niemand das Spiel, gibt es eine Siedler IV history collection gruppe oder sowas?
Und ist nur LAN möglich oder auch normaler Multiplayer?

mika_465
18-11-18, 15:56
Das schnelle Spiel funktioniert bei mir noch immer nicht. Selten steht da "Fehler bei der Verbindung", häufig kommt eine Leere Lobby.
In der ist dann nicht einmal mein eigener Name zu sehen, der Spielname ist dann "(Troja) [Name eines Hosts]", bei Spieler steht "0/[X]) und es ist eine andere Karte zu sehen, als ich ausgesucht habe. Wenn ich dann zurück drücke, bin ich nicht mehr bei "Multiplayer", sondern bei meinen Saves.

Hab schon alles ausprobiert. Firewall aus, UPnP aktiviert, Ports freigegeben, andere Karten ausgewählt, zufällige Karte ausgewählt.. nichts hat geholfen.
Das Komische ist, dass ich zwei mal in eine Lobby mit einer anderen Person gekommen bin, ohne etwas zu ändern danach aber nicht mehr.

Spiel per "Erstellen" und invite funktioniert übrigens.

Bin ein wenig am Verzweifeln :confused:

Habe IPv6 und einen compal broadband networks Router von Vodafone.

Kristalikadi
18-11-18, 17:29
Die Schnelles Spiel Lobby funktioniert derzeit nicht ordentlich. Wie ich in meinem ersten Post beschrieben habe kann man sich unter Umständen in einer Lobby finden sofern 2 Spieler die gleiche Karte ausgewählt haben. Aber auch das geht nur in 50% der fällte gut. Bei Random maps ist es unmöglich sich über Schnelles Spiel zu finden.

mika_465
18-11-18, 18:40
Ich habe heute aber ein schnelles Spiel auf einer zufälligen Karte mit jemand Fremden spielen können. Er war der Host und ich hatte eigentlich eine normale Karte ausgewählt, aber es hat funktioniert.

masterchiefaph
24-11-18, 00:10
Bei uns im Lan funktionierte alles bis der berüchtigte Desync-Error auftrat. So leider kein anständiger Multiplayer möglich. Ich hoffe sehr auf einen nachträglichen Patch der dies behebt (Vielleicht einfach alle 5 mins autosave?). Die anderen hier genannten Fehler hatten wir zum Glück nicht.

Elda_87
26-11-18, 14:08
Gibt es etwas neues bzgl. des Desync-Errors? Ich habe gestern mit Freunden im Multiplayer gespielt (Gegen die KI) und das war schon recht störend, wir mussten sehr häufig alte Spielstände laden. :(

Lukadora95
28-11-18, 00:35
Das neuste was es gibt, ist dass es mittlerweile im englischen Forum unter bekannte Bugs gelistet wurde. Es bleibt abzuwarten ob wir vielleicht hoffen dürfen :)

Oxyrhynchos78
30-11-18, 11:10
Moin, gibt es eigentlich auch schon Lösungen für das Fatal Error Problem?
Ich hatte sehr gehofft, dass dieses bei der HE nicht mehr vorhanden wäre....

aceb88
01-12-18, 23:57
Es kann ja wohl nicht angehen das Ubisoft so alte Spiele re-released mit angepriesenen "Verbesserungen" die eine angebliche Windows 10 Kompatibilität versprechen und es immer noch dieselben Bugs wie vor etlichen Jahren gibt.

Folgender Punkt ist auch wichtig:

VERBESSERUNGEN: „Windows 10“-kompatibel, Autospeicher-Funktion, 4K- und Doppelmonitor-Unterstützung, Mehrspielermodus über Uplay.

Wie kann es sein das Ich in Siedler 3 und 4 seit ein paar Tagen keine Mehrspieler Spiele mehr starten kann? Zu Release ging das wenigstens, jetzt sind alle Knöpfe einfach ausgegraut.

Mal wieder ein totaler Reinfall von Ubisoft. Hätte man sich ja denken können.
Nichts als Geldmacherei mit so wenig Aufwand wie möglich,

S4ndwichGurk3
02-12-18, 12:21
Wie kann es sein das Ich in Siedler 3 und 4 seit ein paar Tagen keine Mehrspieler Spiele mehr starten kann? Zu Release ging das wenigstens, jetzt sind alle Knöpfe einfach ausgegraut.

Also bei mir funktioniert alles. Vielleicht hast du irgendetwas falsch gemacht.

Schabanane
05-12-18, 14:03
Moin gibt es schon news zum Desync Bugg?
Ist er gefixt?

Morphoiz
05-12-18, 21:28
Moin gibt es schon news zum Desync Bugg?
Ist er gefixt?

Die letzte Info ist, dass sich die Entwickler den Bug ansehen. Seitdem gibt es noch keine neuen Infos.

Ubi-Thorlof
06-12-18, 18:31
Korrekt, wir haben noch keine Neuigkeiten zu diesem Punkt.
Eine Behebung des Problems ist allerdings für ein zukünftiges Update geplant.

Frankybraun65
08-12-18, 15:38
Hy,

ich habe heute SiedlerIV bei euch gekauft. Ich kann nicht, wie es beworben wird, im Mehrspielmodus spielen. Ich kann nicht mal KEIN Mehrspielerspiel erstellen.

Echt toll diese Ankündigung, ich fühle mich derbe auf den Arm genommen !

Frankybraun65
08-12-18, 15:39
Ich kann Kein Mehrspielerspiel erstellen, sollte es heißen

Jojjaa
08-12-18, 17:22
Ich schmeiße mal einen weiteren Bug/Fehler in den Raum:

Spiele auf einem 21:9 Monitor mit nativ 3440x1440. Will ich das Spiel in dieser Auflösung starten stürzt es direkt beim Start ab mit "S4 Main Exe Fatal Error". (Windows 10 64bit)

https://s15.directupload.net/images/181208/temp/nqsp2izz.png (https://www.directupload.net/file/d/5295/nqsp2izz_png.htm)



Erst wenn ich die Auflösung auf 2560x1080 reduziere startet das Spiel ganz normal wie es sollte. Da mit 4K Support geworben wird, hoffe ich das dies noch gefixt wird. Starte ich im Fenster Modus unter 3440x1440, läuft es, bis man das Fenster größer als 2560x1080 Pixel gezogen hat, dann crasht es wieder. Bei 21:9 scheint das Spiel also bei mehr als 2560x1080 Pixel Auflösung ein Problem zu haben. Siedler 3 hingegen kommt damit problemlos klar.

HonorRaider
11-12-18, 11:25
Ich habe die Frageleider schonmal gestellt aber keine Atnwort bekommen... es geht um den Map Editor... weil dieser icht funktioniert,nicht da ist und haste nicht gesehen...

Map Editor Fehler:

Die gewünschte Sprache ist nicht verfügbar

(Hat das vieleicht was damit zu tun wenn man vorher noch irgendwie die Gold Edition zumlaufen gekriegt hat auf WIndows 10?! Den Bevor die HE Edition raus kam habe ich es mit 100 Bug fix und Patches irgenwie zum laufen gekriegt, kann es also sein das diese alte Version irgendwie der HE sich gegenseictig schaden?! bzw.: Inkompatiebel sind?!)

Weil seit dem ich das alte BlueByte Verzeichnes entfernt (Verschoben) habe kommt nicht mehr die 16 bit Fehlermeldung sondern die Sprache Fehlermeldung

Kaisaschnitt7
19-12-18, 15:17
Nach 20-30 mins Desync. Bitte beheben S4 nicht online spielbar. Hab mich so darauf gefreut das es online wieder spielbar is aber dann die grosse entäuschung Desync.
Bitte ubisoft Fixt diesen bug.
Siedler 3 Läuft tadellos ohne den Desync fehler.

Kaisaschnitt7
19-12-18, 15:26
NUR wenn du eine Random generierte Map nutzt. Stimmt leider net kommt trotzdem DESYINC:(:(:(:(:(

Freazer97
23-12-18, 03:16
Ich hab das Problem sobald ich auf Multiplayer klicke und dann sehe dass der Erstelle button deaktiviert ist. Was kann ich tun?

S4ndwichGurk3
23-12-18, 11:30
Ich hab das Problem sobald ich auf Multiplayer klicke und dann sehe dass der Erstelle button deaktiviert ist. Was kann ich tun?

Hatte ich auch mal, dann bin ich einfach zurück ins Hauptmenü und ich wieder auf mehrspieler und irgendwann hats wieder funktioniert. Zur Not vielleicht auch mal siedler neu starten und wenn alles nichts bringt, pc Neustarten bzw ab- und anmelden

MagierLWM
23-12-18, 19:22
Kurze Frage, was macht man, wenn nach ein paar Minuten im Spiel (mal früher, mal später) die Verbindung zum anderen Spieler immer abbricht und der Router kein UPNP unterstützt?

Dampfkarotte
23-12-18, 19:36
Hatte ich auch mal, dann bin ich einfach zurück ins Hauptmenü und ich wieder auf mehrspieler und irgendwann hats wieder funktioniert. Zur Not vielleicht auch mal siedler neu starten und wenn alles nichts bringt, pc Neustarten bzw ab- und anmelden

Moin,

als ich hier im Forum las, dass der lästige desync bug jetzt endlich behoben sei habe ich mir heute voller Vorfreude mit zwei Freunden die Siedler IV History Edition gekauft und heruntergeladen. Leider ziemlich enttäuschend, da wir auch nach mehrern Stunden Forum lesen, ausprobieren und Ports freigeben nicht einmal eine Mehrspieler Partie starten konnten. Im Mehrspieler Menü sind die Einträge für "Schnelles Spiel" und "Erstellen" einfach ausgegraut und nicht anklickbar.

Version müsste die aktuellste sein, da erst heute installiert. Host Rechner Windows10 Pro 64 bit, per LAN an der Fritzbox, UDP und TCP ports (https://forums-de.ubi.com/showthread.php/199560-Siedler-4-FAQ-Netzwerk-Fehler-Bugs) von der Fritzbox an rechner weitergeleitet, UPnP aktiviert. 2 Client rechner auch win10 die im WLAN der Fritz Box hängen. "Erstellen" ist bei allen Dreien ausgegraut. In Uplay sind wir als Freunde hinzugefügt. Haben auch schon ne weile gewartet in der Lobby, spiel mehrfach neu installiert, uplay neugestartet, rechner neu gestartet, firewall aus, windows firewall aus...

Hier die Liste an Ports die wir inzwischen nach und nach alle freigegeben haben (aus verschiedenen anleitungen hier im Forum und bei ubisoft)

https://img.picload.org/image/dccapowi/freigegebeneports.jpg

S4ndwichGurk3
23-12-18, 23:47
Merkwürdig. Ich habe nicht einen einzigen Port freigegeben und es funktioniert (manchmal ist der Button erst ausgegraut, aber dann nach mehrmaligem Hauptmenü->Merhrspieler Wechsel geht's)

Vielleicht mal mit Hamachi probieren. Wenn ihr in einem Netzwerk seid, wird so etwas wie eine virtuelle LAN Verbindung zwischen euch aufgebaut. das macht man normalerweise, wenn man keine ports freischalten möchte.

Blutwurst15
29-12-18, 13:50
Hey alle beisammen,

also das mit dem DESYNC funktioniert irgendwie schon besser, mein Bruder und ich konnten die letzte Runde zum 1. mal "komplett" spielen, es war TOLL :D:o
Aber beim letzten KI-Turm oder kurz davor kam dann doch der DESYNC, später als je zuvor und auch zu einem nicht mehr relevanten Zeitpunkt, DOCH er erschien.
Vllt doch noch nicht komplett gelöst?

MFg

MagierLWM
31-12-18, 15:39
Selbsterstellte Karten scheinen auch nicht zu funktionieren (bzw. es funktionieren nur die Mitgelieferten). Wenn man ein Spiel mit einer eigenen Karte erstellt und einer beitritt, dann stürzt für den das ganze Spiel ab ohne Fehlermeldung.

S4ndwichGurk3
04-01-19, 12:39
Selbsterstellte Karten scheinen auch nicht zu funktionieren (bzw. es funktionieren nur die Mitgelieferten). Wenn man ein Spiel mit einer eigenen Karte erstellt und einer beitritt, dann stürzt für den das ganze Spiel ab ohne Fehlermeldung.

Das Problem hatten wir auch mal. Ihr müsst sichergehen, dass ihr wirklich genau die selbe Karte habt und diese im Installationsordner -> Maps -> User sind. (Wenn man Einzelspiele spielt, können die Karten auch im Maps Ordner in den Dokumenten sein)
Nachdem wir dann die map aus beiden ordnern gelöscht haben und beide diese dann in den User Ordner eingefügt haben, hats funktioniert.

Tobsn1991
05-01-19, 20:27
Moin,
ich habe folgendes Problem, wenn ich Einzelspieler spielen will und ich mir die Position auf der Karte, z.B. die Nr. 5 auswähle, um wie damals wo man auswählen konnte welche Farbe, welches Folk und welches Wappen man haben will, wird alles ausgegraut. Ich kann nichts mehr machen, es steht dann hinter meinem Namen „Kicken“ obwohl ich im Singleplayer bin und wenn ich dann dies drücke, werde ich aus dem Spiel geschmissen und bekomme den Fehler Code: (0xc0000005 at 0x00544325! ). Wenn ich mit Esc. rausgehe komm ich ins Hauptmenü und hab dann das selbe Problem wieder :/ .

Hat da jmd vllt eine Idee woran das liegt, oder ist das nun normal?

mfg Tobi

CookieButton
10-01-19, 16:09
Hey alle beisammen,

also das mit dem DESYNC funktioniert irgendwie schon besser, mein Bruder und ich konnten die letzte Runde zum 1. mal "komplett" spielen, es war TOLL :D:o
Aber beim letzten KI-Turm oder kurz davor kam dann doch der DESYNC, später als je zuvor und auch zu einem nicht mehr relevanten Zeitpunkt, DOCH er erschien.
Vllt doch noch nicht komplett gelöst?

MFg

Bei der ursprünglichen Version hat es schon zwei Versuche gegeben die Desyncs durch Opcode-Patches zu beheben. (Also nicht durch die eigentlichen Entwickler)
Das Problem ist der letztendliche Nachweis, dass ein Fix auch wirklich funktioniert (sei es jetzt komplett, oder dass die Häufigkeit verringert wird). Alles was bei raus kommt sind annekdotische Meldungen ohne feste Teststruktur. Dass es mal geht und mal nicht ist ja schon bekannt...
Wieso bei den genannten zwei Versuchen eben diese gar nichts bewirkt hatten, hatte ich mir einmal im Disassembly angesehen und in einem anderen Forum ausführlich erläutert.
Was mir und ein paar anderen Leuten, die an einer technischen Lösung interessiert sind fehlt, ist der eigentliche Quellcode. Bis jetzt haben wir nur ein recht grobes Verständnis basierend auf dem bisschen was man erahnen kann und den Möglichkeiten einen solchen Spieltypus und die Herausforderungen zur Synchronisation über mehrere Klienten zu bewerkstelligen.

Bleikugel90
30-01-19, 19:35
Habe mir das Spiel vorhin gekauft in der Hoffnung mit ein paar Kumpels alte Zeiten aufleben zu lassen.
Wie es aussieht fängt das Drama dort an wo es damals aufgehört hat.
Obwohl bei der Installation die Sprache deutsch angegeben wurde, wird alles auf englisch angezeigt. Beim Versuch die Konfiguration zu ändern wird mit der Fehlermeldung quittiert, dass die config (Datei, was auch immer, im Benutzerordner nicht gefunden werden kann und damit kein Speichern möglich ist.
Desweiteren stürzt das Spiel bei mir immer ab, wenn ich versuche eine Sitzung zu speichern. Egal welche Mission ich starte.
Ist das ein Fehler der sich bei anderen Reproduzieren lässt. Woran könnte das liegen? Habe schon die Installtion mit Adminrechten ausgeführt und der Ordner für die Konfiguration existiert auf jeden Fall (auch wenn ich ihn manuell erstellen musste).
Fehlermeldung: Fatal error: Exception 0xc0000005 at 0x013afc06

Finde es ziemlich bescheiden noch mal 9 Euro für ein Spiel ausgegeben zu haben, was genau solche Probleme hat wie die Spiele, die ich damals schon als CD erworben habe... Wenn ich basteln will installiere ich Siedler 4 von der CD.

muf
31-01-19, 21:02
Hi,
die Config und Sprache zu Siedler 4 passt du im Uplay Menu an:
https://forums-de.ubi.com/showthread.php/199452-History-Collection-Starter-Guide-SPRACHE-SAVEGAMES-etc?p=2570256&viewfull=1#post2570256

NudelNorbert
15-02-19, 21:31
Guten Abend,

leider habe ich ein Problem... Die Siedler 3 & 4 lassen sich bei mir nicht starten... Bei Die Siedler 3 passiert einfach gar nichts, nachdem ich es versuche mit Uplay zu starten und bei Die Siedler 4 habe ich einen Fatal Error: Exception 0xc0000005 at 0x10015e00. Hat da jemand eine Lösung oder kann mir sagen, wo dran es liegt? ich bin mittlerweile am verzweifeln :( Ironischerweise läuft bei Siedler 2 ohne Probleme. Habe bis jetzt folgendes ausprobiert:

Diverse Auflösungen
Starten als Admin
Kompatibilitätsmodus
Uplay starten als Admin

Mein System:

Ryzen 7 1700
GTX 1080
Asus X470 Rog strix
Trident Z RGB 3200
SSDs sowie HDDs
Dual Monitor
Win10

Vielen Dank für eure Hilfe!

Crazy-Cooper
06-03-19, 16:36
Ich bekomme es nicht hin ein Schiff abzureissen. Ist das ein BUG? Oder mache ich was falsch?

Spiel ist Siedler 4 History Edition auf Windows 10


Wäre cool wenn mir jemand helfen könnte...

muf
06-03-19, 18:22
Ging das jemals in die Siedler 4? Warum willst du das tun?

Crazy-Cooper
07-03-19, 18:12
Ich habe in einigen Foren gelesen das es über die Entf Taste funktionieren soll. Klappt aber nicht, deswegen Frage ich hier.

muf
07-03-19, 21:29
Mir ist nicht bekannt, dass das jemals funktioniert hätte - auch nicht mit Entf :confused:

chris260389
10-03-19, 18:22
Hallo,

ich kann leider die Auflösung nicht ändern. Alle fixes die ich im Internet dazu finden kann helfen nicht da in der History Edition wohl anders aufgebaut ist. Aus diesem Grund greifen auch Änderungen in Config-Files nicht.

Gibt es irgendwo einen Trick um auf 1920x1080 umzustellen?

muf
10-03-19, 23:58
Bei Siedler4 HE? Das Spiel verwendet immer deine Desktop Auflösung im Fullscreen Modus ... :confused:

Blacky03.10
21-03-19, 23:13
Ich weiß nicht ob das schon angesprochen wurde aber Das Handel System mit Markplatz Spuck ständigt Fantal Error aus Vllt mal Angucken Kumpel hat gesehen ein Esel Nimmt rohstoffe auf und bum haben alle ein Fatal Error bekommen

CookieButton
21-03-19, 23:22
Jo, seit Release 2001 bekannt und nicht behoben worden. Die meisten Absturzstellen sind Resultat von Flüchtigkeitsfehlern mit denen der Code normalerweise gar nicht kompiliert werden würde (fpermissive lässt grüßen).
Wenn dein Kumpel Logfiles hat, darf er sie mir gerne schicken.

Blacky03.10
21-03-19, 23:51
Jo, seit Release 2001 bekannt und nicht behoben worden. Die meisten Absturzstellen sind Resultat von Flüchtigkeitsfehlern mit denen der Code normalerweise gar nicht kompiliert werden würde (fpermissive lässt grüßen).
Wenn dein Kumpel Logfiles hat, darf er sie mir gerne schicken.

Nach unseren spiel kann ich sie dir schicken denn er ist im Forum noch nicht registriert.

CookieButton
21-03-19, 23:53
Kein Problem, mein Account geht nirgendwo hin. Logs sind in %User%\Documents\TheSettlers4\Log

Blacky03.10
22-03-19, 01:57
Kein Problem, mein Account geht nirgendwo hin. Logs sind in %User%\Documents\TheSettlers4\Log

hab sie dir Privat gesendet.

Tig3rc1aw
30-04-19, 23:43
Moin,
ich habe folgendes Problem, wenn ich Einzelspieler spielen will und ich mir die Position auf der Karte, z.B. die Nr. 5 auswähle, um wie damals wo man auswählen konnte welche Farbe, welches Folk und welches Wappen man haben will, wird alles ausgegraut. Ich kann nichts mehr machen, es steht dann hinter meinem Namen „Kicken“ obwohl ich im Singleplayer bin und wenn ich dann dies drücke, werde ich aus dem Spiel geschmissen und bekomme den Fehler Code: (0xc0000005 at 0x00544325! ). Wenn ich mit Esc. rausgehe komm ich ins Hauptmenü und hab dann das selbe Problem wieder :/ .

Hat da jmd vllt eine Idee woran das liegt, oder ist das nun normal?

mfg Tobi

Hallo,

ich habe exakt das selbe Problem und da bisher noch keiner darauf eingegangen ist,
will ich das hier noch mal hervorholen.

Das Spiel ist frisch installiert und nicht modifiziert.
Gibt's da ne Lösung für oder einen Bugfix?

Mfg